• Hey, guest user. Hope you're enjoying NeoGAF! Have you considered registering for an account? Come join us and add your take to the daily discourse.
  • The Politics forum has been nuked. Please do not bring political discussion to the rest of the site, or you will be removed. Thanks.

Analysis Hardware Steam FPS Counter- Is It Accurate?

Velius

Member
Dec 22, 2016
1,048
1,495
505
Some of you know I recently built a new rig. It's got a Ryzen 7 5800X and Gaming OC RTX 3080 Ti. It has a Samsung 980 Pro 1TB gaming SSD. I don't think it's an exaggeration to call it state of the art.

However I'm noticing something. On Witcher 3 of all things, the Steam FPS counter stays at 60, but I could swear there are... not stutters per se, but stoppage of frames. Geralt himself doesn't seem to have any lack of fluidity, but the scenery as it scrolls by, seems to be running at less than 60.

I mean... it's certainly possible, I guess, that Witcher 3 is just... that much of a problem. But it just doesn't seem to make sense. I run Doom Eternal Maxed with Ray Tracing and it's 144 fps the entire time. Is the Steam FPS counter reliable?

Also by the way my monitor is an MSI Optix Mag27CQ.
 

Guilty_AI

Member
Apr 12, 2020
4,859
9,764
720
is your monitor 144hz? If so there's your problem.
You're supposed to cap the fps at 144, 72, 36, etc; not 60. Preferably with v-sync
 
  • Like
Reactions: VEZ1R

Stuart360

Member
Sep 9, 2018
10,106
24,617
770
Should just use Rivatuner as it not only has a good FPS counter, but you can also see how much cpu and gpu usage you are using.
 
  • Like
Reactions: Phase and Md Ray
Jul 25, 2014
1,385
889
590
It's not always accurate, and while iD's implementation in the new Doom games serves it's purpose (sometimes even more details), it's stuck to the game and not a public open app for all games.

Always stick to the combo of Rivatuner Statistics Server + MSI Afterburner for the best, close to accurate results, more details on your complete usage of your hardware like CPU Cores/threads/clocks, GPU Load/clocks, RAM real-time usage/clocks etc.
 
  • Like
Reactions: Soodanim and Md Ray

drotahorror

Member
Mar 21, 2014
8,161
1,711
720
Some of you know I recently built a new rig. It's got a Ryzen 7 5800X and Gaming OC RTX 3080 Ti. It has a Samsung 980 Pro 1TB gaming SSD. I don't think it's an exaggeration to call it state of the art.

However I'm noticing something. On Witcher 3 of all things, the Steam FPS counter stays at 60, but I could swear there are... not stutters per se, but stoppage of frames. Geralt himself doesn't seem to have any lack of fluidity, but the scenery as it scrolls by, seems to be running at less than 60.

I mean... it's certainly possible, I guess, that Witcher 3 is just... that much of a problem. But it just doesn't seem to make sense. I run Doom Eternal Maxed with Ray Tracing and it's 144 fps the entire time. Is the Steam FPS counter reliable?

Also by the way my monitor is an MSI Optix Mag27CQ.

Sounds like vsync is on and locked to 60fps. Your monitor supports 144hz provided you've actually set it up properly, your refresh rate should be 144hz. If you play a game locked to 60fps it's probably going to stutter like mad. Lock to 72. (half of 144).

Spend 1000's on a nice PC and don't know basic shit.
 

Complistic

Member
Apr 4, 2011
4,816
185
810
Steam's counter is more or less accurate. Have you chosen 144hz in the windows settings? Its probably defaulted to 60hz if I had to guess.
 
  • Like
Reactions: Velius

Velius

Member
Dec 22, 2016
1,048
1,495
505
I unlocked frames but I still see stutters. Frames in Steam on Witcher 3 vary from 90 to 120, but I still see... what I can only describe as lost frames. Very subtle, but
 

Velius

Member
Dec 22, 2016
1,048
1,495
505
Sounds like vsync is on and locked to 60fps. Your monitor supports 144hz provided you've actually set it up properly, your refresh rate should be 144hz. If you play a game locked to 60fps it's probably going to stutter like mad. Lock to 72. (half of 144).

Spend 1000's on a nice PC and don't know basic shit.
I appreciate all feedback. How do I lock it at 72?
I can confirm that monitor is set to 144hz
 

baphomet

Member
Oct 29, 2011
6,947
2,788
970
Denver, CO
I think it does, but I don't know how to activate it.
You would know if it supported it because you would have paid a premium for it.

Unless you're using any sort of VRR you need to have it locked to an integer of 144.
 
Last edited:
Jan 3, 2021
422
635
295
you should enable frametime graph via afterburner

that way you can detect frame dips on real time

shut off vsync, turn on freesync/gsync (right click desktop>nvidia control panel>gsync on the left, and then tick the enable box)

if u dont see gsync sub-menu in nvidia control panel, u have to

1) enable freesync/gsync from your monitor's osd. u have to dig around monitor osd settings
2) u have to be on displayport if you're on a freesync screen

witcher 3 can be quite finnicky with its own framerate limiter, and usually have bad frametimes by itself

your best bet would be to enable gsync, and then locking framerate to 60-70-80 or whatever u want via rivatuner. that way u will have smooth and consistent frametimes

even then witcher 3 is a bit jumpy... i dont remember Novigrad fondly.

---

checked your monitor model, it appears to be a freesync panel. u can safely enable gsync. but as i said

1) u need to be on displayport

2) if you cant see gsync in nvidia control panel, u have to probably enable freesync first from monitor's osd
 
Last edited:
Jan 3, 2021
422
635
295



i see freesync option in monitor's osd settings. u have to find it and enable it (hopefully you're connected with displayport cable)

and then;




i'd also say tick the windowed and fullscreen option. it worked flawless for me for the entirety of the year, no issues so far. i think nv fixed and cleaned up issues with it
 
Last edited:

Velius

Member
Dec 22, 2016
1,048
1,495
505
Holy shit that did it. It runs smooth as silk, even in Novigrad.

Only thing is my CPU heats up to 77 but damn it runs flawlessly!
 
Jan 3, 2021
422
635
295
Holy shit that did it. It runs smooth as silk, even in Novigrad.

Only thing is my CPU heats up to 77 but damn it runs flawlessly!

remember, you must also employ a framerate limiter of 141 (so that the game engine does not jump to anything above 144 and create tears)

if you can still notice tears here and there and if it bothers you, you can enable vsync globally in nvdia control panel's global 3d settings. this will make sure you will never see any tears

but most of the time a fps limit of 141 will do the trick. i use a limit of 138 because i don't like the idea of vsync being enabled in any form of shape (call me stubborn). at 138 frame limit, vsync disabled, and freesync enabled, i never noticed/saw any tears or judders
 
Last edited:

Velius

Member
Dec 22, 2016
1,048
1,495
505
remember, you must also employ a framerate limiter of 141 (so that the game engine does not jump to anything above 144 and create tears)

if you can still notice tears here and there and if it bothers you, you can enable vsync globally in nvdia control panel's global 3d settings. this will make sure you will never see any tears

but most of the time a fps limit of 141 will do the trick. i use a limit of 138 because i don't like the idea of vsync being enabled in any form of shape (call me stubborn). at 138 frame limit, vsync disabled, and freesync enabled, i never noticed/saw any tears or judders
Thank you so much!!!
 
  • Like
Reactions: johnsilverwick

Velius

Member
Dec 22, 2016
1,048
1,495
505
remember, you must also employ a framerate limiter of 141 (so that the game engine does not jump to anything above 144 and create tears)

if you can still notice tears here and there and if it bothers you, you can enable vsync globally in nvdia control panel's global 3d settings. this will make sure you will never see any tears

but most of the time a fps limit of 141 will do the trick. i use a limit of 138 because i don't like the idea of vsync being enabled in any form of shape (call me stubborn). at 138 frame limit, vsync disabled, and freesync enabled, i never noticed/saw any tears or judders
Hey I'm now experiencing a problem, and it appears to be only with Witcher 3. Screen keeps on blinking black. When I say blink, I mean video cuts out. It will come back on for like a second, then cut out again. Do you have any ideas what could be causing this, or how to fix it?

EDIT: AUGH nevermind, I restarted my computer and that fixed it. Ugh, sorry
 
Last edited:
Jan 3, 2021
422
635
295
Hey I'm now experiencing a problem, and it appears to be only with Witcher 3. Screen keeps on blinking black. When I say blink, I mean video cuts out. It will come back on for like a second, then cut out again. Do you have any ideas what could be causing this, or how to fix it?

EDIT: AUGH nevermind, I restarted my computer and that fixed it. Ugh, sorry
check your cable connections, maybe something is loose? thats a weird issue

yeah its fixed but it may come back later, i hope it does not though
 

Velius

Member
Dec 22, 2016
1,048
1,495
505
check your cable connections, maybe something is loose? thats a weird issue

yeah its fixed but it may come back later, i hope it does not though
I also lost controller function as well. But again, it was only for Witcher 3. I booted up Doom Eternal and it was fine. It is indeed a weird issue.

Thank you for your guidance man-- I'll keep you posted
 

Velius

Member
Dec 22, 2016
1,048
1,495
505
check your cable connections, maybe something is loose? thats a weird issue

yeah its fixed but it may come back later, i hope it does not though
Okay it's doing it again. Is it possible the GSync thing is causing an issue?
 
Jan 3, 2021
422
635
295
Okay it's doing it again. Is it possible the GSync thing is causing an issue?
no it shouldn't be doing that

sadly i have no idea what is causing it, disabling gsync for a time and play again with your tried and true setup, if that does not happen again, you can say its gsync maybe
 
  • Like
Reactions: Velius

Velius

Member
Dec 22, 2016
1,048
1,495
505
no it shouldn't be doing that

sadly i have no idea what is causing it, disabling gsync for a time and play again with your tried and true setup, if that does not happen again, you can say its gsync maybe
Well I restarted my comp again, and as expected it's working fine. I actually just did the Famerate cap in NVidia panel, and put it at 141 for everything.

On an unrelated note, that makes Doom Eternal run at 4k with ray tracing at 54 degrees. I can't believe it. DLSS and frame caps are real.

I've been doing roll20 on google with my buddies, it's possible that's somehow related but I don't know. My plan is to go get some grub, then come back and try it again. If it DOESN"T do it, I think it's probably something to do with Chrome, or messing with the Roll20 application online, or maybe both.