• Hey, guest user. Hope you're enjoying NeoGAF! Have you considered registering for an account? Come join us and add your take to the daily discourse.

Spider-Man Miles Morales Save Data Issue, need your help GAF

So long story short I booted up Miles Morales after 7 months since I beat it nearly thrice. To my surprise when I boot up the game it refuses to let me resume my 3 or 4th playthrough. All load save slots are appearing to be empty. I immediately navigated to the PS5 console save storage menu and noticed there are two save files for PS5 version. One dated today and one dated from Feb 2021. For whatever reason, Feb 2021 isn't being read by the game. I then went into the cloud storage and even there I am seeing today's date save data and Feb 2021 save data. I deleted the duplicate entry (i.e. today's save data from both console and cloud) and redownloaded the Feb 2021 save data to the console save data storage. I then tried to re-run the game but no luck, it's still not showing them in the game once I boot to the game's main menu :(

What could the problem be? Have anyone of you faced this issue and is there a fix?
Last edited:
Top Bottom